How to install Google Web Toolkit with Eclipse

Google Web Toolkit (簡稱:GWT)是先以 Java 語言編寫 AJAX 應用程式網頁,然後在編譯成最佳化 Javascript,不但幫助了剛入門 Javascrit,然後又需要撰寫 AJAX 應用程式的工程師很大的幫助,不僅如此,Google App Engine 也提供了 Java 跟 Python 環境,整合了 GWT,讓您可以上傳到 GAE 的空間進行測試,GWT 目的是產生具有高效能性的 Web 應用程式,您不需要是 Javascript 專家也可以做到,GWT 用在 Google 相當多的服務,例如 Google Wave, 新版的 Google AdWords 可以參考這裡更多實際範例。它是開放姓原始碼(open source),完全免費,您也可以參與 GWT 的開發。 Google Plugin for Eclipse 支援 Google Web Toolkit 跟 Google App Engine 開發,我們可以直接安裝此 Plugin 就可以開始上手 GWT,當製作完成之後,就可以上傳到 GAE,直接打開提供的網址就可以看到成果了。 首先安裝 Google Plugin for Eclipse,先去下載 Eclipse 3.5 (Galileo) 最新版,打開 Eclipse 1. 選擇 Help -> Install New Software Google Web Toolkit (by appleboy46) 2. 在 Work With: 填入 http://dl.google.com/eclipse/plugin/3.5 Google Web Toolkit (by appleboy46) 3. 將 Plugin 跟 SDKS 全部選取,接下來按下一步就可以完成
  • 安装失败,求解。
    An error occurred while collecting items to be installed
    session context was:(profile=epp.package.jee, phase=org.eclipse.equinox.internal.provisional.p2.engine.phases.Collect, operand=, action=).
    No repository found containing: osgi.bundle,org.eclipse.mylyn,3.3.1.v20091215-0000-e3x
    No repository found containing: osgi.bundle,org.eclipse.mylyn.bugzilla.core,3.3.1.v20091215-0000-e3x
    No repository found containing: osgi.bundle,org.eclipse.mylyn.bugzilla.ide,3.3.1.v20091215-0000-e3x
    No repository found containing: osgi.bundle,org.eclipse.mylyn.bugzilla.ui,3.3.1.v20091215-0000-e3x
    No repository found containing: org.eclipse.update.feature,org.eclipse.mylyn.bugzilla_feature,3.3.1.v20091215-0000-e3x
    No repository found containing: osgi.bundle,org.eclipse.mylyn.commons.core,3.3.1.v20091215-0000-e3x
    No repository found containing: osgi.bundle,org.eclipse.mylyn.commons.ui,3.3.1.v20091215-0000-e3x
    No repository found containing: osgi.bundle,org.eclipse.mylyn.compatibility,3.3.1.v20091215-0000-e3x
    No repository found containing: osgi.bundle,org.eclipse.mylyn.context.core,3.3.1.v20091215-0000-e3x
    No repository found containing: osgi.bundle,org.eclipse.mylyn.context.ui,3.3.1.v20091215-0000-e3x
    No repository found containing: org.eclipse.update.feature,org.eclipse.mylyn.context_feature,3.3.1.v20091215-0000-e3x
    No repository found containing: osgi.bundle,org.eclipse.mylyn.discovery.core,3.3.1.v20091215-0000-e3x
    No repository found containing: osgi.bundle,org.eclipse.mylyn.discovery.ui,3.3.1.v20091215-0000-e3x
    No repository found containing: osgi.bundle,org.eclipse.mylyn.help.ui,3.3.1.v20091215-0000-e3x
    No repository found containing: osgi.bundle,org.eclipse.mylyn.ide.ant,3.3.1.v20091215-0000-e3x
    No repository found containing: osgi.bundle,org.eclipse.mylyn.ide.ui,3.3.1.v20091215-0000-e3x
    No repository found containing: org.eclipse.update.feature,org.eclipse.mylyn.ide_feature,3.3.1.v20091215-0000-e3x
    No repository found containing: osgi.bundle,org.eclipse.mylyn.java.tasks,3.3.1.v20091215-0000-e3x
    No repository found containing: osgi.bundle,org.eclipse.mylyn.java.ui,3.3.1.v20091215-0000-e3x
    No repository found containing: org.eclipse.update.feature,org.eclipse.mylyn.java_feature,3.3.1.v20091215-0000-e3x
    No repository found containing: osgi.bundle,org.eclipse.mylyn.monitor.core,3.3.1.v20091215-0000-e3x
    No repository found containing: osgi.bundle,org.eclipse.mylyn.monitor.ui,3.3.1.v20091215-0000-e3x
    No repository found containing: osgi.bundle,org.eclipse.mylyn.resources.ui,3.3.1.v20091215-0000-e3x
    No repository found containing: osgi.bundle,org.eclipse.mylyn.tasks.bugs,3.3.1.v20091215-0000-e3x
    No repository found containing: osgi.bundle,org.eclipse.mylyn.tasks.core,3.3.1.v20091215-0000-e3x
    No repository found containing: osgi.bundle,org.eclipse.mylyn.tasks.ui,3.3.1.v20091215-0000-e3x
    No repository found containing: osgi.bundle,org.eclipse.mylyn.team.cvs,3.3.1.v20091215-0000-e3x
    No repository found containing: osgi.bundle,org.eclipse.mylyn.team.ui,3.3.1.v20091215-0000-e3x
    No repository found containing: org.eclipse.update.feature,org.eclipse.mylyn.team_feature,3.3.1.v20091215-0000-e3x
    No repository found containing: osgi.bundle,org.eclipse.mylyn.wikitext.confluence.core,1.2.0.v20091215-0000-e3x
    No repository found containing: osgi.bundle,org.eclipse.mylyn.wikitext.confluence.ui,1.2.0.v20091215-0000-e3x
    No repository found containing: osgi.bundle,org.eclipse.mylyn.wikitext.core,1.2.0.v20091215-0000-e3x
    No repository found containing: osgi.bundle,org.eclipse.mylyn.wikitext.help.ui,1.2.0.v20091215-0000-e3x
    No repository found containing: osgi.bundle,org.eclipse.mylyn.wikitext.mediawiki.core,1.2.0.v20091215-0000-e3x
    No repository found containing: osgi.bundle,org.eclipse.mylyn.wikitext.mediawiki.ui,1.2.0.v20091215-0000-e3x
    No repository found containing: osgi.bundle,org.eclipse.mylyn.wikitext.tasks.ui,1.2.0.v20091215-0000-e3x
    No repository found containing: osgi.bundle,org.eclipse.mylyn.wikitext.textile.core,1.2.0.v20091215-0000-e3x
    No repository found containing: osgi.bundle,org.eclipse.mylyn.wikitext.textile.ui,1.2.0.v20091215-0000-e3x
    No repository found containing: osgi.bundle,org.eclipse.mylyn.wikitext.tracwiki.core,1.2.0.v20091215-0000-e3x
    No repository found containing: osgi.bundle,org.eclipse.mylyn.wikitext.tracwiki.ui,1.2.0.v20091215-0000-e3x
    No repository found containing: osgi.bundle,org.eclipse.mylyn.wikitext.twiki.core,1.2.0.v20091215-0000-e3x
    No repository found containing: osgi.bundle,org.eclipse.mylyn.wikitext.twiki.ui,1.2.0.v20091215-0000-e3x
    No repository found containing: osgi.bundle,org.eclipse.mylyn.wikitext.ui,1.2.0.v20091215-0000-e3x
    No repository found containing: org.eclipse.update.feature,org.eclipse.mylyn.wikitext_feature,1.2.0.v20091215-0000-e3x
    No repository found containing: org.eclipse.update.feature,org.eclipse.mylyn_feature,3.3.1.v20091215-0000-e3x

  • 呵呵,虽然同是3.5,可能以前的那个有点问题,从官方下了最新的,就装好了。